Eggheads: putloglev issue ?

Jonathan Rudolph skralg at gmail.com
Tue Dec 29 09:54:32 CST 2009


  If you are using an version of eggdrop prior to 1.6.19+ctcpfix,
please upgrade and verify the percieved bug again.
  If the problem continues, we'd like some more info in order to
reproduce the problem, such as any 3rd party patches and/or modules
you may have included in your compile.
  Mostly, we'd like to see the 'logfile' commands from your .conf file
(or any other 'logfile' commands located in your scripts), as we think
this is most likely a configuration issue.

Thanks, and Happy Holidays

simple


On Tue, Dec 29, 2009 at 4:03 AM, CrazyCat <crazycat at c-p-f.org> wrote:
> Hello there,
>
> I've two eggdrops linked and using my chanrelay tcl to relay what is said
> on chanA (eggA) to chanB (eggB).
> I'm trying to add in the chanB logfile the relayed message, so I've add in
> my receive procs:
> cr:log p $chan $sentence
>
> the cr:proc is:
> proc cr:log { lev chan line } {
>   putloglev $lev "$chan" "$line"
>   putlog "$chan $line saved"
>   return 0
> }
>
> When it is called, nothing is added to my logfile, neither the chanB
> message nor the chanA message, but I see in my party-line "#chanA bla bla
> saved", so the proc is well called and seems to work.
>
> If I comment the call to cr:log in the different procedures, eggB log well
> what is said on chanB.
>
> Any idea ?
>
> Thanks by advance.
> Regards,
> CrazyCat
>
> --
> Réseau IRC Francophone: http://www.zeolia.net
> Aide informatique: http://www.c-p-f.org
> Communauté Eggdrop Francophone: http://www.eggdrop.fr
>
>



More information about the Eggheads mailing list