Eggheads: Install Issues

Uwe Schindler uwe at thetaphi.de
Tue May 4 11:21:51 CST 2004


You should:
a) create a static version of TCL and delete the ".so" file of TCL previous 
installed (there should then be a ".a" file of same name)
b) use "make static" to make a static linked eggdrop.

If you want a shared modules/shared TCL version of eggdrop you can do one 
of the following:
a) install TCL at the standard place /usr/lib or /usr/local/lib (needs root 
privilege)
b) set the environment variable LD_LIBRARY_PATH before starting eggdrop, 
e.g. with a command line like:
         LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/place/with/tcl.so ./eggdrop

Uwe

At 02:11 04.05.2004, you wrote:
>I am attempting to install Eggdrop on my server for a
>client.  I have successfully done this on a box using
>cPanel/WHM control panel.  This box uses Ensim Pro
>RHEL and I have errors on install.
>
>When I first tried to do the install I got errors
>about TCL not being installed when I ran ./configure.
>I downloaded and installed TCL for this client.  When
>I try to install now here is what I get...
>
>./configure
>     Configure is done.
>     Type 'make config' (etc)
>
>make config
>     You can now compile the bot, using "make".
>
>make
>     (Compiling does fine, linking returns an error.)
>./eggdrop: error while loading shared libraries:
>libtcl8.4.so: cannot open shared object file: No such
>file or (line is truncated)
>make: *** [modegg] Error 127
>
>
>Can someone point me in the right direction please?  I
>think it is a DFU error on my part...
>
>DB
>
>=====
>---------------------------------------------
>http://www.obscenitees.com/janet.html
>---------------------------------------------
>
>
>
>
>__________________________________
>Do you Yahoo!?
>Win a $20,000 Career Makeover at Yahoo! HotJobs
>http://hotjobs.sweepstakes.yahoo.com/careermakeover

-----
Uwe Schindler
Addr 1: Bamberger Str. 24a, D-96049 Bamberg
Addr 2: Drausnickstr. 153, D-91052 Erlangen
http://www.thetaphi.de - http://www.schindlers-software.de
eMails: uwe at thetaphi.de (private); info at schindlers-software.de (company)
Tel./Fax: +49 700 PCLATEIN (+49 700 72528346)

Schindlers Software - Home of Schindlers PC-LATEIN 3.10
DIE Software zum Lateinlernen!  




More information about the Eggheads mailing list