Eggdev: [Bug 448] New: channel join can be zero

bugzilla-daemon at tsss.org bugzilla-daemon at tsss.org
Wed May 24 01:46:16 CST 2006


http://www.eggheads.org/bugzilla/show_bug.cgi?id=448

           Summary: channel join can be zero
           Product: Eggdrop 1.6
           Version: 1.6.18 CVS
          Platform: PC
        OS/Version: All
            Status: NEW
          Severity: minor
          Priority: P3
         Component: Module: channels.mod
        AssignedTo: eggdev at eggheads.org
        ReportedBy: DeKus at gmx.net


While confirming a script about channel online time, I stumpled over an
intresting issue (to be honest the bot is running 1.7.0, but since this tree is
going to be dropped and I am confident the issue is present in both version, I
report the bug here):

-snip-
[-RO^Bot-] [10:41:52] tcl: evaluate (.tcl): getchanjoin bytetales #rns
[-RO^Bot-] Tcl: 0
-snap-

-snip-
[-RO^Bot-] [10:27:48] tcl: builtin dcc call: *dcc:channel De_Kus 13 #rns
.....
[-RO^Bot-]  NICKNAME      HANDLE      JOIN  IDLE  USER at HOST
[-RO^Bot-] @[-RO^Bot-]    *          15May       <- it's me!
[-RO^Bot-]  ByteTales     *           ---     8d 
~ByteTales at euirc-15dd9274.disi.info
.....
-snap-

You look right... there is user on the channel, without ever joined the channel.
I suppose this happened because I reset all channels every 1h, because of
possible desyncs and mainly because of vhosts (which update on nick auth). So
probably the user "joined" via "WHO" and not via "JOIN. At least thats the only
reasonable explaination that comes into my mind.



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the Eggdev mailing list