Bugs: make install bug on SuSE Linux

Dillon Amburgey dillona at dillona.com
Sun Jan 29 21:30:19 CST 2006


 
Hi,
I got it to work here's what I did:
1. It does not exist in acconfig, so I did mv ./mkinstalldirs acconfig/
2. Then I did the regular ln command
3. I reran make install and it worked.
I think it should be moved to acconfig in the cvs tree to accord with
the ./INSTALL file.
Thank you,
Dillon Amburgey

-----Original Message-----
From: Sven Trenkel [mailto:list at semidefinite.de] 
Sent: Sunday, January 29, 2006 9:04 PM
To: Eggheads Bug Reporting List
Cc: Dillon Amburgey
Subject: Re: Bugs: make install bug on SuSE Linux

Dillon Amburgey wrote:
> Hi,
> I just downloaded the current 1.9 tree from cvs and followed the 
> directions perfectly. Build went fine for the most part and on make 
> install, I get the following errors:

> /bin/sh `case "acconfig/mkinstalldirs" in /*) echo 
> "acconfig/mkinstalldirs" ;; *) echo "../acconfig/mkinstalldirs" ;; 
> esac` /home/d/dillona/eggdrop/devel//share
> /bin/sh: ../acconfig/mkinstalldirs: No such file or directory
> make[1]: *** [install-data-yes] Error 127
> make[1]: Leaving directory `/home/d/dillona/eggdrop/eggdrop1.9/po'
> make: *** [install-recursive] Error 1
> dillona at suse:~/eggdrop/eggdrop1.9>"
> I basicly copied the lines I figured were relevent. If any more 
> information is needed, contact me.

I know I ran into this error myself but I can't remember what caused it.

Did you do step 2 of the INSTALL file?

    2. Create the following symlinks in the Eggdrop 1.9 root directory:
         ln -s acconfig/mkinstalldirs ./
         ln -s configure.ac configure.in

The file "./mkinstalldirs" may already exist. In this case you'll have
to delete it ("rm mkinstalldirs") or use the "-f" option with ln ("ln
-sf acconfig/mkinstalldirs ./").

CU
   Sven



More information about the Bugs mailing list