Bugs: make install bug on SuSE Linux

Dillon Amburgey dillona at dillona.com
Sun Jan 29 19:53:21 CST 2006


Hi,
I just downloaded the current 1.9 tree from cvs and followed the
directions perfectly. Build went fine for the most part and on make
install, I get the following errors:
"PATH="$PATH:/sbin" ldconfig -n /home/d/dillona/eggdrop/devel//modules
----------------------------------------------------------------------
Libraries have been installed in:
   /home/d/dillona/eggdrop/devel//modules
 
If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'
 
See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
..../../acconfig/install-help.sh "/home/d/dillona/eggdrop/devel/" .
make[3]: Leaving directory
`/home/d/dillona/eggdrop/eggdrop1.9/modules/blowfish'
make[2]: Leaving directory
`/home/d/dillona/eggdrop/eggdrop1.9/modules/blowfish'
make[2]: Entering directory `/home/d/dillona/eggdrop/eggdrop1.9/modules'
make[3]: Entering directory `/home/d/dillona/eggdrop/eggdrop1.9/modules'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/home/d/dillona/eggdrop/eggdrop1.9/modules'
make[2]: Leaving directory `/home/d/dillona/eggdrop/eggdrop1.9/modules'
make[1]: Leaving directory `/home/d/dillona/eggdrop/eggdrop1.9/modules'
Making install in src
make[1]: Entering directory `/home/d/dillona/eggdrop/eggdrop1.9/src'
make[2]: Entering directory `/home/d/dillona/eggdrop/eggdrop1.9/src'
test -z "/home/d/dillona/eggdrop/devel/" || mkdir -p --
"/home/d/dillona/eggdrop/devel/"
  /bin/sh ../libtool --mode=install /usr/bin/install -c 'eggdrop'
'/home/d/dillona/eggdrop/devel//eggdrop'
/usr/bin/install -c .libs/eggdrop /home/d/dillona/eggdrop/devel//eggdrop
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/home/d/dillona/eggdrop/eggdrop1.9/src'
make[1]: Leaving directory `/home/d/dillona/eggdrop/eggdrop1.9/src'
Making install in po
make[1]: Entering directory `/home/d/dillona/eggdrop/eggdrop1.9/po'
/bin/sh `case "acconfig/mkinstalldirs" in /*) echo
"acconfig/mkinstalldirs" ;; *) echo "../acconfig/mkinstalldirs" ;; esac`
/home/d/dillona/eggdrop/devel//share
/bin/sh: ../acconfig/mkinstalldirs: No such file or directory
make[1]: *** [install-data-yes] Error 127
make[1]: Leaving directory `/home/d/dillona/eggdrop/eggdrop1.9/po'
make: *** [install-recursive] Error 1
dillona at suse:~/eggdrop/eggdrop1.9>"
I basicly copied the lines I figured were relevent. If any more
information is needed, contact me.
 
Thank you,
Dillon Amburgey



More information about the Bugs mailing list